RE: [PECL-CVS] cvs: pecl /intl php_intl.c /intl/doc grapheme_api.php /intl/grapheme grapheme.h grapheme_string.c /intl/tests grapheme.phpt
| From: | Derick Rethans | Date: | Fri, 02 May 2008 16:24:01 +0000 |
| Subject: | RE: [PECL-CVS] cvs: pecl /intl php_intl.c /intl/doc grapheme_api.php /intl/grapheme grapheme.h grapheme_string.c /intl/tests grapheme.phpt | ||
| References: | 1 | Groups: | php.pecl.cvs |
| Request: | Send a blank email to pecl-cvs+get-10691@lists.php.net to get a copy of this message | ||
On Thu, 1 May 2008, Ed Batutis wrote:
>
> > I use "you" for all intl developers :) We sent many many mails (this
> > list and internals) about the poor naming of these new functions and
> > got zero reply so far.
>
> Personally I think the naming is OK - maybe not perfect, but what is
> perfect? Anyway, there was a long discussion about this on the php-icu list.
> I think that's where you might want to post your thoughts.
It doesn't have to be perfect, but there is a reason why we have some
form of naming convention. The most important thing is that we want
function names to be descriptive - grapheme_extract vs grapheme_extractb
vs grapheme_extractc is hardly that. In this case they're not even
following the ICU names AFAICS. Allthough I've been following the
php-icu list as well, I still find it strange that all most of the other
(non php-icu) devs see is that you want to push to get this into the
core. If that's the case, you should work with us - and not just ignore
and trying to do it *only* your way.
regards,
Derick
--
Derick Rethans
http://derickrethans.nl | http://ezcomponents.org | http://xdebug.org