Also, in any case, I'd be very much opposed to such a generic name even if it's allowed in PECL.
I have as much of a distaste for OOP as the next guy, but if the code is written and someone out there *may* want to use it, I see no reason to preclude it from PECL. I agree that core is the wrong place and it needs a non-generic name, I'd offer: objString, String_Object, ooString, or a vanity name like JH_String, or something whimsical like sOOP (P_SOOP even?).
As to release timing, I'd suggest that Jessie wait until unicode has been merged and some of the lingering questions have been resolved so that he can make changes to his own API prior to public release.
If nothing else, this extensions sounds like a wonderful example to other developers of the kinds of things that can be done with object handlers in PHP5.
-Sara