php function renaming
| From: | Zak Greant | Date: | Tue, 06 Mar 2001 01:05:51 +0000 |
| Subject: | php function renaming | ||
| Groups: | php.qa | ||
| Request: | Send a blank email to php-qa+get-2461@lists.php.net to get a copy of this message | ||
Hello All,
Chuck Hagenbuch and I had a quick discussion about function renaming earlier
in the day. After we talked, I asked Chuck if we could bring the discussion
onto the list. Here is a summary of what we discussed.
CH> 1. Why are the IMAP functions losing underscores, when almost
CH> everything else is gaining them?
ZG> My goal was to make the extensions internally consistent
ZG> with the least amount of effort. Doing this should save
ZG> developers time by helping them reference the manual less
ZG> when they are in the middle of production coding.
ZG> Dropping the underscores for a few functions caused less
ZG> change than adding them to everything else.
CH> Okay - with the goal of moderation and consistency within
CH> extensions, this makes perfect sense.
CH> 2. While you're at it, why not rename the imap_ functions to
CH> mail_ or cclient_ or something else more generic that
CH> indicates that they work with pop3 and nntp, also?
ZG> Again, I was trying to make the least change. My belief is
ZG> that many things should be completely renamed - however, Andi
ZG> said be moderate, so I am trying to be moderate. :)
CH> I'd argue that this is perhaps a special case; so many people
CH> have been misled as to what those functions can do since
CH> they're prefixed with imap_ ...
ZG> As long as we can get group consensus on this issue, I am all
ZG> for it! :)
ZG> This would also let us move to the most common naming scheme
ZG> of extension_verb_...
Ciao,
Zak