Re: imap-ssl support...

From: Date: Thu, 22 Nov 2001 19:04:38 +0000
Subject: Re: imap-ssl support...
References: 1  Groups: php.qa 
Request: Send a blank email to php-qa+get-4015@lists.php.net to get a copy of this message
There may or may not be an imapssl.so file (or similarly named -- go to your IMAP source and do "make install" again and see what it does) that is in whatever directory the IMAP guys thought was better than the OS distribution guys for libraries, and that directory is not listed in /etc/ld.so.conf (or whatever directory/file your OS distribution guys thought was the right place to put *that* stuff) and so when you did ldconfig (or the OS did during boot) it never found the imapssl.so file to be added into the Operating System. The preceding paragraph would be much shorter if Un*x geeks would settle on some reasonable file structure standard and everybody would actually *FOLLOW* the damn thing. :-) Disclaimer: I don't actually know anything about imap-ssl specifically. It's entirely possible that that's *NOT* where the IMAP SSL code gets loaded in, and something was wrong in your httpd.conf (look at AddModule) or your PHP compilation (look at config.log and config.cache in the PHP source directory) or your Apache configuration (probably config.log and config.cache in the Apache source directory).
Hi, maybe my problem but if i use --with-imap-ssl i got hits error after httpd start: ./apachectl start Syntax error on line 190 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: Undefined symbol "ssl_onceonlyinit" ./apachectl start: httpd could not be started ?? Any tips or help ?? --Marco -- PHP Quality Assurance Mailing List <http://www.php.net/> To unsubscribe, e-mail: php-qa-unsubscribe@lists.php.net For additional commands, e-mail: php-qa-help@lists.php.net To contact the list administrators, e-mail: php-list-admin@lists.php.net
-- WARNING richard@zend.com email address is an endangered species Use ceo@l-i-e.com instead

« previous php.qa (#4015) next »