This would translate well into
<?php
namespace vendor\file;
function functionname(){}
?>
However, I wonder if you are in essence doing the exact same thing as
the proposed namespace naming for OOP? i.e.
{vendor}_{package}_function
You just define package as the file containing the function.
Hmm, perhaps. Perhaps vendor is not the right name for our top level though. Most OSS projects only have one offering. We have Phorum. Its the project, the group, the app. All one name for all levels. Now, something like Horde could have a true vendor and package separation.
Brian.