Re: [PHP4BETA] cvs: /php4/ext/aspell aspell.c /php4/ext/com COM.c/php4/ext/cybercash cybercash.c /php4/ext/dav dav.c /php4/ext/db db.c/php4/ext/dba
dba.c /php4/ext/dbase dbase.c /php4/ext/domxml domxml.c/php4/ext/filepro filepro.c /php4/ext/ftp php_ftp.c /php4/ext/hyperwave hw.c/php4/ext/icap
php_icap.c /php4/ext/imap imap.c /php4/ext/interbase interbase.c/php4/ext/ldap ldap.c /php4/ext/mcal php_mcal.c /php4/ext/msql
php_msql.c/php4/ext/mssql php_mssql.c /php4/ext/mysql php_mysql.c /php4/ext/oci8 oci8.c/php4/ext/odbc php_odbc.c velocis.c /php4/ext/oracle oracle.c
/php4/ext/pcrephp_pcre.c /php4/ext/pgsql pgsql.c /php4/ext/posix posix.c /php4/ext/readlinereadline.c /php4/ext/session session.c /php4/ext/snmp
snmp.c /php4/ext/standardbasic_functions.c /php4/ext/sybase sybase.c /php4/ext/sybase_ct php_sybase_ct.c/php4/ext/sysvsem sysvsem.c
/php4/ext/sysvshm sysvshm.c /php4/ext/wddx wddx.c/php4/ext/xml xml.c /php4/ext/yp yp.c
| From: | Stig S. Bakken | Date: | Mon, 06 Mar 2000 20:46:53 +0000 |
| Subject: | Re: [PHP4BETA] cvs: /php4/ext/aspell aspell.c /php4/ext/com COM.c/php4/ext/cybercash cybercash.c /php4/ext/dav dav.c /php4/ext/db db.c/php4/ext/dba dba.c /php4/ext/dbase dbase.c /php4/ext/domxml domxml.c/php4/ext/filepro filepro.c /php4/ext/ftp php_ftp.c /php4/ext/hyperwave hw.c/php4/ext/icap php_icap.c /php4/ext/imap imap.c /php4/ext/interbase interbase.c/php4/ext/ldap ldap.c /php4/ext/mcal php_mcal.c /php4/ext/msql php_msql.c/php4/ext/mssql php_mssql.c /php4/ext/mysql php_mysql.c /php4/ext/oci8 oci8.c/php4/ext/odbc php_odbc.c velocis.c /php4/ext/oracle oracle.c /php4/ext/pcrephp_pcre.c /php4/ext/pgsql pgsql.c /php4/ext/posix posix.c /php4/ext/readlinereadline.c /php4/ext/session session.c /php4/ext/snmp snmp.c /php4/ext/standardbasic_functions.c /php4/ext/sybase sybase.c /php4/ext/sybase_ct php_sybase_ct.c/php4/ext/sysvsem sysvsem.c /php4/ext/sysvshm sysvshm.c /php4/ext/wddx wddx.c/php4/ext/xml xml.c /php4/ext/yp yp.c |
||
| References: | 1 | Groups: | php.version4 |
| Request: | Send a blank email to php-version4+get-11635@lists.php.net to get a copy of this message | ||
Andi Gutmans wrote:
>
> On Mon, 6 Mar 2000, Andrei Zmievski wrote:
>
> > On Mon, 06 Mar 2000, Andi Gutmans wrote:
> > > What is the reason for this patch? Do you need this change for a specific
> > > reason?
> >
> > Yes. It's necessary so that there's a uniform naming convention and it
> > also makes it possible to easily find out which extensions are loaded
> > through extension_loaded() function.
>
> How wasn't this possible before? Maybe we should have a "Pretty name" too?
It was possible, but there was no way of knowing what an extension's
name was, "SNMP", "Snmp", "PHP_SNMP" etc. But a "pretty
name" field is
a good idea. It's probably a Good Thing to fix extension api versioning
once and for all while we're at it.
- Stig