RC1 DSO Problem..

From: Date: Sun, 02 Apr 2000 19:24:08 +0000
Subject: RC1 DSO Problem..
Groups: php.version4 
Request: Send a blank email to php-version4+get-13014@lists.php.net to get a copy of this message
After the long and difficult ordeal of installing the PostgreSQL 6.5 .debs on my Debian 2.1 machine, I recompiled PHP4 RC1 only to have this error when I try to start Apache: # apache start Syntax error on line 100 of /etc/apache/httpd.conf: Cannot load /usr/lib/apache/1.3/libphp4.so into server: \ /usr/lib/apache/1.3/libphp4.so: undefined symbol: _dl_default_scope Here is a list of the packages I updated in order to satisfy PGSQL's dependencies and the new version I installed: apt 0.3.18 ldso 1.9.11-5 libc6 2.1.3-7 libncurses5 5.0-6 libpgsql2 6.5.3-16 libreadline4 4.1-1 The Postgres packages were all version 6.5.3-16, I installed the main, -clients, and -dev packages. PHP ./configure options are --with-pgsql=/usr/include/postgresql --with-apxs=/usr/sbin/apxs Unfortunately the undefined symbol doesn't really alert me to where the difficulty is. I had no similar problems when I compiled PHP for my old 6.3.x version of Postgres (with older versions of all packages listed above). Any thoughts would be appreciated. Thanks! -Jesse

« previous php.version4 (#13014) next »