PHP4.0.0 ISAPI & IIS5 & MS SQL
| From: | Pavel Kalian | Date: | Mon, 22 May 2000 11:27:54 +0000 |
| Subject: | PHP4.0.0 ISAPI & IIS5 & MS SQL | ||
| Groups: | php.version4 | ||
| Request: | Send a blank email to php-version4+get-15373@lists.php.net to get a copy of this message | ||
Hi,
I just gave a try to the ISAPI version of PHP 4.0.0 with Frank M. Kromann's
MS SQL module DLL's from http://download.swwing.com on
my W2k workstation
and found out that the combination is at all unusable:
when second (it doesn't matter which) mssql_* function gets called the 'PHP
has encountered an Access Violation at XXXXXXXX' error message appears and
PHP4 ISAPI filter stops working at all and neither stopping/starting the
w3svc helps.
When used as ISAPI module, PHP4 also seems not to load the extensions
specified in php.ini and I always have to dl them from the script.
With the CGI version everything works just fine.
Is there some explanation for the ISAPI version behaviour?
TIA
Pavel