Re: [PHP4BETA] --with-mm error
| From: | Sascha Schumann | Date: | Mon, 22 May 2000 19:22:38 +0000 |
| Subject: | Re: [PHP4BETA] --with-mm error | ||
| References: | 1 | Groups: | php.version4 |
| Request: | Send a blank email to php-version4+get-15451@lists.php.net to get a copy of this message | ||
On Mon, 22 May 2000, Vadim Tkachenko wrote:
> I install mm-library into /usr
> (./configure --prefix=/usr)
>
> I compile PHP4
> ./configure --with-apxs=/usr/local/apache/bin/apxs --with-mysql --enable-tra
> ck-vars --with-dbase --disable-debug --disable-pic --with-oci8 --with-oracl
> e --enable-inline-optimization --disable-xml --with-mm=/usr
>
>
> When I start Apache -
>
> Cannot load /usr/local/apache/libexec/libphp4.so into server:
> /usr/local/apache/libexec/libphp4.so: undefined symbol: mm_malloc
> [FAILED]
>
> Why?
Try running ldconfig as root. If that does not work, check whether
libphp4.so is linked against libmm (ldd libexec/libphp4.so on Linux).
- Sascha