Re: [PHP4BETA] cvs: php4 /ext/standard/ Makefile.in basic_functions.c levenshtein.c php_string.h

From: Date: Tue, 23 May 2000 15:20:16 +0000
Subject: Re: [PHP4BETA] cvs: php4 /ext/standard/ Makefile.in basic_functions.c levenshtein.c php_string.h
References: 1  Groups: php.version4 
Request: Send a blank email to php-version4+get-15554@lists.php.net to get a copy of this message
On Tue, 23 May 2000, Andrei Zmievski wrote: > On Tue, 23 May 2000, Hartmut Holzgraefe wrote: > > hholzgra Tue May 23 16:10:37 2000 EDT > > > > Added files: > > /php4/ext/standard levenshtein.c > > > > Modified files: > > /php4/ext/standard Makefile.in basic_functions.c php_string.h > > Log: > > added function "int levdist(string str1, string str2)" > > that will calculate the Levenshtein distance between two > > strings (faster and possibly more accurate than similar_text()) > > Please call it lev_dist() or maybe find a better name... :) I agree with Andrei that the name should be changed. The standard is to divide works with underscores. I would even go with levenshtein() because no one will know what lev_dist() is and it sounds like various things. Andi

« previous php.version4 (#15554) next »