Re: RE: Unable to load dynamic library
| From: | Mike Beamish | Date: | Sat, 08 Jul 2000 05:29:43 +0000 |
| Subject: | Re: RE: Unable to load dynamic library | ||
| References: | 1 2 | Groups: | php.windows |
| Request: | Send a blank email to php-windows+get-949@lists.php.net to get a copy of this message | ||
Hi Robert,
I've backtracked a bit and re-established what I had done to get everything working for PHP
4.0.0 (as an Apache module). There were fewer problems getting the CGI version to work, so I'll
only summarise the Apache module setup:
1.. I have a Win 95 system at home and a WinNT 4 SP6 system at work, but I'll describe my
Win95 setup here. I also run MySQL and Oracle 8.0.5 on a Linux Box at home, and connect to SQL
Server 7 at work.
2.. Source and binaries were obtained from the OpenSA project (http://www.opensa.org). I have
tried my setup with their binaries and my own - re-built from their source. The current OpenSA
release includes Apache 1.3.12, PHP 4.0.0 as a module, OpenSSL 0.9.5a, mod_ssl 2.6, and a few other
modules.
3.. I used the swwwing libraries (i.e. from php_build.zip), and OpenLDAP 1.2.7 sources for
recompiling the calendar, imap, ldap, mssql, oracle, and zlib modules.
4.. Apache is installed in c:/apache. All PHP modules and DLL's are in c:/apache/modules.
5.. The system path is:
PATH=c:\windows;c:\windows\COMMAND;C:\PERL\BIN;C:\OPENSSL\BIN;C:\APACHE\MODULES;C:\ORACLE\ORA81\BIN;C:\MSSQL7\BINN
6.. c:/windows/php.ini includes the following settings:
[PHP]
...
include_path =
doc_root =
user_dir =
extension_dir = ./ ; extensions are in same place as apachemodulephp4.dll and php4ts.dll
; extension_dir = c:\apache\modules\ ; this works too
...
extension=php_calendar.dll
;extension=php_mssql70.dll (no client installed on Win 95 box)
extension=php_zlib.dll
extension=php_imap.dll
extension=php_ldap.dll
7.. c:/apache/conf/httpd.conf includes the following commands relevant to PHP:
LoadModule php4_module modules/apachemodulephp4.dll
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
I hope that all helps.
Regarding problems with PHP version 4.0.1, there were 2 patches released shortly after, which fix
the problem in php.exe with the 1st release, however I have got the apache module version working,
even with fixes suggested in this NG.
Regards
Mike
"Robert J Sherman" <webmaster@snr-graphics.com> wrote in message news:4.3.1.2.20000702052015.00adf9e0@snr-graphics.com...
> wonderful news, but didn't work for me...
>
> perhaps you can provide us all a sample from you ini file, so we can see
> xactly' what's what.
>
> I tried a full path, a full machine path and still got the exact errors.
>
> And yes, the error message below, is precisely the same one I get when I
> try to load
> swwwing's libraries..
>
> course the worst part is the php4.0.1 won't even run for me.. though 4.0.0
> will.
>
>
>
> At 08:48 PM 7/2/00 +1200, you wrote:
> >Hi,
> >I saw a number of postings about this subject, but no sensible replies for
> >some of those. I have had the same problem the reported by the posters, and
> >managed to fix it by adding the directories with the PHP extension DLL's to
> >the PATH in addition to specifiying extension_dir in php.ini. It seems that
> >the extension DLL's are unable to find themselves!
> >
> >Typically this should fix error messages like:
> > PHP Fatal error: Unable to load dynamic library 'php_calendar.dll'
> > A device attached to the system is not functioning in Unknown on line 0
> >
> >Mike
> >
>