500 internal server error bug
| From: | Andrew Saturn | Date: | Wed, 17 Oct 2001 22:06:53 +0000 |
| Subject: | 500 internal server error bug | ||
| References: | 1 | Groups: | php.windows |
| Request: | Send a blank email to php-windows+get-9901@lists.php.net to get a copy of this message | ||
in the current version (4.0.6?) there is a slightly annoying bug (which might actually be two)
when you run the Apache server (1.3.20) for a little while, PHP eventually stops working (it "falls asleep" -- the PHP ms-dos window just stays in the tray doing nothing and has to be force quit), and all requests to the site for a PHP file return a 500 "internal server" error, like "blah.php" -- "blah.html" or any other non-PHP files are downloaded perfectly.
this also happens when you cause a 404 with a php file, example:
http://www.roogroup.com/this_file_does_not_exist_and_never_will.php
<-- returns a 500 (instead of 404), even when PHP isn't "asleep"
also, both leave only this in the error log:
[Wed Oct 17 18:00:41 2001] [error] [client 1.2.3.4] couldn't spawn child process: c:/php/php.exe
the only way around this that I've found is restarting Apache and closing any locked up instances of PHP.
I won't do that for now, so that you can all see at my server:
http://www.roogroup.com/
I was told this had been fixed in a new version, but I can't seem to find this version anywhere. if anyone knows if this is my fault, and how to fix it, PLEASE let me know, otherwise, I hope the folks at php.net can fix this in the next win32 release.
my info:
AMD K6\2 450mhz w/ 128 MB ram
Windows ME (4.90.3000)
Apache 1.3.20
PHP Win32 4.0.6
MySQL (newest... forget the version)
<-- note about MySQL: I had the bug before I installed MySQL, so I don't think this is causing it.
regards,
-andrew saturn