Re: [domxml] namespaces / exception / extensionname

From: Date: Fri, 18 Apr 2003 16:14:22 +0000
Subject: Re: [domxml] namespaces / exception / extensionname
References: 1 2  Groups: php.xml.dev 
Request: Send a blank email to php-xml-dev+get-78@lists.php.net to get a copy of this message
> > - Exceptions: Here again. To use as default or not? W3C Standards rely a > > lot on Exceptions, so it would be nice to have and Rob summed it up quite > > right: > > Absolutely exceptions, it is the standard. When there is a standard for > something, it should be followed as closely as possible. It aids in > documentation and understanding when we do that. If dual development is > done, then on php4 errors would be be used. Well, for the dom stuff - yes. For the other stuff (related to DOM), we should use the standard error to exception mapping (I'll be proposing it to php-dev@ later today). > Also, are function names going to follow the standard or are they being > phpized? (getElementById or get_element_by_id) Again, I think the DOM > standard should be followed, and not php's standard. > We could do that. Actually, with ZE2, we could require that case sensitive names be followed as well. > > > - Extension Name: It looks like domxml5 will be more or less completely > > uncompatible to domxml4, so you have to port your applications before you > > can upgrade to PHP5 ('though, it should be possible to write a wrapper in > > PHP-Userland..). With this in mind, should we really replace the domxml > > with a new one or just introduce a new, different extension and fade out > > the old in a later php5 version. This would make upgrading to PHP5 for > > people using domxml much easier, as they don't have to go through the > > domxml code immediately. > > use a new name....xmldom, libxml, or just plain dom. well, its a lot more than dom. how about just xml, and then have the different components labeled/properly ns'd (dom, sax, xslt, etc.) > > > Furthermore, domxml is a very misleading name for the whole extension. > > domxml is not only about DOM stuff, since a long time. It has support for > > XSLT, XPath, Validation, XInclude, etc... Furthermore libxml2 would allow > > for implementing more XML stuff like XML Schema/relaxng Validation, SAX, > > XMLTextReader Interface etc... Therefore IMHO a more generic name would be > > a "Good Thing". > > > > Do an XML (or LIBXML) namespace, and have subnamespaces for each. > > LIBXML_DOM > LIBXML_SCHEMA > LIBXSLT > ...etc... Kinda. Not so pretty, but it exists. -Sterling -- "First they ignore you, then they laugh at you, then they fight you, then you win." - Gandhi

« previous php.xml.dev (#78) next »