Re: [ZEND-ENGINE-CVS] cvs: Zend / zend_API.c zend_builtin_functions.c zend_compile.c zend_constants.c zend_execute.c zend_execute_API.c
zend_operators.c zend_operators.h
| From: | Andi Gutmans | Date: | Tue, 08 Oct 2002 21:45:24 +0000 |
| Subject: | Re: [ZEND-ENGINE-CVS] cvs: Zend / zend_API.c zend_builtin_functions.c zend_compile.c zend_constants.c zend_execute.c zend_execute_API.c zend_operators.c zend_operators.h |
||
| References: | 1 2 | Groups: | php.zend-engine.cvs |
| Request: | Send a blank email to php-zend-engine-cvs+get-477@lists.php.net to get a copy of this message | ||
Any news? Can we change it back to zend_str_tolower()?
Andi
At 04:41 PM 10/1/2002 -0400, Ilia A. wrote:
On October 1, 2002 03:43 pm, Andi Gutmans wrote: Can we rename zend_str_tolower_nlc to something which is understandable? Maybe zend_str_tolower_no_locale? Or is there any reason not to just keep it as zend_str_tolower? (Are some places still using the old version?) Andi The name change, zend_str_tolower_nlc seemed like a good idea at the time, but zend_str_tolower_no_locale is just as good and probably easier to understand. I did not alter the original function, because zend_str_tolower is used in a number of places inside php4/ and I did not want to break the functionality. On closer examination I have reviewed the use of the zend_str_tolower() function and it appears to be used only in a few places: com, overload, rpc, wddx extensions, browscap.c and user_streams.c I'll need to check that code to determine if that won't break any functionality. Ilia At 06:39 PM 9/26/2002 +0000, Ilia Alshanetsky wrote:-- Zend Engine CVS Mailing List (http://cvs.php.net/) To unsubscribe, visit: http://www.php.net/unsub.phpiliaa Thu Sep 26 14:39:28 2002 EDTModified files:/Zend zend_API.c zend_builtin_functions.c zend_compile.c zend_constants.c zend_execute.c zend_execute_API.c zend_operators.c zend_operators.hLog: Fixed bug #18556 -- Zend Engine CVS Mailing List (http://cvs.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php