Bug #13023 Updated: symbol ap_block_alarms: referenced symbol not found
| From: | dlt at lunanet dot biz | Date: | Mon, 25 Feb 2002 12:00:26 +0000 |
| Subject: | Bug #13023 Updated: symbol ap_block_alarms: referenced symbol not found | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-1006@lists.php.net to get a copy of this message | ||
ID: 13023
Updated by: dlt@lunanet.biz
Reported By: zaino@mfn.unipmn.it
Status: Closed
Bug Type: Apache related
Operating System: Solaris 8 sparc 20
PHP Version: 4.0.6
New Comment:
This fix works.
System is Sparc solaris 8 (10/01). gcc 2.95.2. Apache 1.3.23,
php-4.1.1.
Tried different gcc versions (2.8.1, 2.95.2, 3.0.4) and either they
gave me this error or they core dumped when starting apache while
trying to load libphp.so. I did not go back and test if it worked ok on
the other compilers. Was just happy I got it working and figured it was
best to leave well enough alone.
Apache configuration was:
./configure --enable-module=headers --enable-module=expires
--enable-module=info --enable-module=log_agent
--enable-module=log_referer --enable-module=rewrite --enable-module=so
--enable-module=ssl --prefix=/usr/local/pkg/apache/apache-1.3.23
--enable-shared=max --enable-rule=SHARED_CORE
php config was:
./configure --with-apxs=/usr/local/pkg/apache/apache-1.3.23/bin/apxs
--enable-bcmath --enable-calendar --enable-ftp
--with-imap=/tmp/imap-2001a --with-mysql
--prefix=/usr/local/pkg/php/php-4.1.1
--with-imap-ssl=/usr/local/pkg/openssl/openssl-0.9.6c
Sorry if this reopened a bug ticket!
Previous Comments:
------------------------------------------------------------------------
[2001-10-02 19:17:52] sniper@php.net
No feedback, considered fixed.
------------------------------------------------------------------------
[2001-08-29 09:33:49] sniper@php.net
Try this configure line for Apache:
./configure --enable-shared=max --enable-rule=SHARED_CORE
--Jani
------------------------------------------------------------------------
[2001-08-29 08:00:50] zaino@mfn.unipmn.it
The error is:
/local/httpd/bin/apachectl configtest
Syntax error on line 206 of /local/httpd/conf/httpd.conf:
Cannot load /local/httpd/libexec/libphp4.so into server: ld.so.1:
/local/httpd/bin/httpd: fatal: relocation error: file
/local/httpd/libexec/libphp4.so: symbol ap_block_alarms: referenced
symbol not found
I've compiled apache with:
./configure --prefix=/local/apache/httpd --enable-module=so
make and install are ok
I've compiled php whith:
./configure --with-apxs=/local/httpd/bin/apxs
--with-config-file-path=/local/php/lib --without-mysql
--prefix=/local/php
make and install are ok
I am on a: SunOS web 5.8 Generic_108528-03 sun4m sparc
SUNW,SPARCstation-20
What is wrong?
Thank's a lot.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=13023&edit=1