From: zaino@mfn.unipmn.it
Operating system: Solaris 8 sparc 20
PHP version: 4.0.6
PHP Bug Type: Dynamic loading
Bug description: symbol ap_block_alarms: referenced symbol not found
The error is:
/local/httpd/bin/apachectl configtest
Syntax error on line 206 of /local/httpd/conf/httpd.conf:
Cannot load /local/httpd/libexec/libphp4.so into server: ld.so.1:
/local/httpd/bin/httpd: fatal: relocation error: file
/local/httpd/libexec/libphp4.so: symbol ap_block_alarms: referenced symbol
not found
I've compiled apache with:
./configure --prefix=/local/apache/httpd --enable-module=so
make and install are ok
I've compiled php whith:
./configure --with-apxs=/local/httpd/bin/apxs
--with-config-file-path=/local/php/lib --without-mysql
--prefix=/local/php
make and install are ok
I am on a: SunOS web 5.8 Generic_108528-03 sun4m sparc
SUNW,SPARCstation-20
What is wrong?
Thank's a lot.
--
Edit bug report at: http://bugs.php.net/?id=13023&edit=1