Bug #13023 Updated: symbol ap_block_alarms: referenced symbol not found

From: Date: Tue, 02 Oct 2001 23:17:52 +0000
Subject: Bug #13023 Updated: symbol ap_block_alarms: referenced symbol not found
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-67163@lists.php.net to get a copy of this message
ID: 13023
Updated by: sniper
Reported By: zaino@mfn.unipmn.it
Old Status: Feedback
Status: Closed
Bug Type: Apache related
Operating System: Solaris 8 sparc 20
PHP Version: 4.0.6
New Comment:

No feedback, considered fixed.


Previous Comments:
------------------------------------------------------------------------

[2001-08-29 09:33:49] sniper@php.net

Try this configure line for Apache:

./configure --enable-shared=max --enable-rule=SHARED_CORE

--Jani


------------------------------------------------------------------------

[2001-08-29 08:00:50] zaino@mfn.unipmn.it

The error is:
/local/httpd/bin/apachectl configtest
Syntax error on line 206 of /local/httpd/conf/httpd.conf:
Cannot load /local/httpd/libexec/libphp4.so into server: ld.so.1: /local/httpd/bin/httpd: fatal:
relocation error: file /local/httpd/libexec/libphp4.so: symbol ap_block_alarms: referenced symbol
not found

I've compiled apache with:
./configure --prefix=/local/apache/httpd --enable-module=so
make and install are ok

I've compiled php whith:
./configure --with-apxs=/local/httpd/bin/apxs --with-config-file-path=/local/php/lib --without-mysql
--prefix=/local/php
make and install are ok

I am on a: SunOS web 5.8 Generic_108528-03 sun4m sparc SUNW,SPARCstation-20

What is wrong?

Thank's a lot.


------------------------------------------------------------------------



Edit this bug report at http://bugs.php.net/?id=13023&edit=1



Thread (3 messages)

« previous php.dev (#67163) next »