#38551 [NEW]: Apache2 will not load php_mysqli.dll under PHP 5.1.5
From: jonmorrow at lycos dot com
Operating system: Win XP Pro SP2
PHP version: 5.1.5
PHP Bug Type: Dynamic loading
Bug description: Apache2 will not load php_mysqli.dll under PHP 5.1.5
Description:
------------
Since upgrading from PHP 5.1.4 to PHP 5.1.5 on a Windows system that was
previously working, mysqli does not load.
Apache 2.0.59
PHP 5.1.5
MySQL 5.0.22
phpMyAdmin 2.8.2
I have also tried with MySQL 5.0.24 -> same problem.
After reverting to PHP 5.1.4, mysqli loads fine.
Expected result:
----------------
The file php_mysqli.dll (16-Aug-2006) appears in the C:\PHP5\ext\
directory, as it should.
The php.ini is set to load extensions as follows (and this is unchanged
from PHP 5.1.4, which worked fine here):
...
extension_dir = "C:\PHP5\ext\"
...
extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_xsl.dll
...
Actual result:
--------------
The Apache error.log says the following each time Apache is restarted:
PHP Warning: PHP Startup: Unable to load dynamic
library 'C:\\PHP5\\ext\\php_mysqli.dll' - The specified
procedure could not be found.\r\n in Unknown on line 0
PHP loads otherwise, and phpMyAdmin works but gives the following error on
its homepage:
Cannot load mysqli extension. Please check your PHP
configuration.
--
Edit bug report at http://bugs.php.net/?id=38551&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=38551&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=38551&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=38551&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=38551&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=38551&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=38551&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=38551&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=38551&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=38551&r=support
Expected behavior: http://bugs.php.net/fix.php?id=38551&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=38551&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=38551&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=38551&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=38551&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=38551&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=38551&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=38551&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=38551&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=38551&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=38551&r=mysqlcfg
Thread (4 messages)
- jonmorrow at lycos dot com