#38551 [Fbk->Csd]: Apache2 will not load php_mysqli.dll under PHP 5.1.5

From: Date: Tue, 22 Aug 2006 23:15:56 +0000
Subject: #38551 [Fbk->Csd]: Apache2 will not load php_mysqli.dll under PHP 5.1.5
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-101147@lists.php.net to get a copy of this message
 ID:               38551
 User updated by:  jonmorrow at lycos dot com
 Reported By:      jonmorrow at lycos dot com
-Status:           Feedback
+Status:           Closed
 Bug Type:         Dynamic loading
 Operating System: Win XP Pro SP2
 PHP Version:      5.1.5
 New Comment:

Thank you, that was (almost) it.  Some unthoughtful program apparently
installed its own copy of libmysql.dll into c:\Windows\System32, which
comes before c:\PHP5 in my path.  Renaming the alien
c:\Windows\System32\libmysql.dll to libmysql.dll.old did the trick.

Cheers!


Previous Comments:
------------------------------------------------------------------------

[2006-08-22 21:23:46] tony2001@php.net

Put libmysql.dll for 5.1.5 to your PATH and restart the web-server.

------------------------------------------------------------------------

[2006-08-22 21:21:55] jonmorrow at lycos dot com

Description:
------------
Since upgrading from PHP 5.1.4 to PHP 5.1.5 on a Windows system that
was previously working, mysqli does not load.

Apache 2.0.59
PHP 5.1.5
MySQL 5.0.22
phpMyAdmin 2.8.2

I have also tried with MySQL 5.0.24 -> same problem.

After reverting to PHP 5.1.4, mysqli loads fine.

Expected result:
----------------
The file php_mysqli.dll (16-Aug-2006) appears in the C:\PHP5\ext\
directory, as it should.

The php.ini is set to load extensions as follows (and this is unchanged
from PHP 5.1.4, which worked fine here):
  ...
extension_dir = "C:\PHP5\ext\"
  ...
extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_xsl.dll
  ...

Actual result:
--------------
The Apache error.log says the following each time Apache is restarted:

  PHP Warning:  PHP Startup: Unable to load dynamic 
  library 'C:\\PHP5\\ext\\php_mysqli.dll' - The specified
  procedure could not be found.\r\n in Unknown on line 0


PHP loads otherwise, and phpMyAdmin works but gives the following error
on its homepage:

  Cannot load mysqli extension. Please check your PHP
  configuration.



------------------------------------------------------------------------


-- 
Edit this bug report at http://bugs.php.net/?id=38551&edit=1


Thread (4 messages)

« previous php.bugs (#101147) next »