#38841 [Fbk->Opn]: Unable to load dynamic library '/usr/lib/php5/extensions/mysqli.so'
| From: | albertbrian at gmail dot com | Date: | Fri, 15 Sep 2006 11:14:57 +0000 |
| Subject: | #38841 [Fbk->Opn]: Unable to load dynamic library '/usr/lib/php5/extensions/mysqli.so' | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-102230@lists.php.net to get a copy of this message | ||
ID: 38841
User updated by: albertbrian at gmail dot com
Reported By: albertbrian at gmail dot com
-Status: Feedback
+Status: Open
Bug Type: Apache2 related
Operating System: OpenSuSE 10.0
PHP Version: 5.1.6
New Comment:
Thank you for your reply.
I've checked libmysqlclient.so in system, and I find libmysqlclient.so
point to libmysqlclient.so.15.0.0
I installed PHP by using rpm packages at
http://ftp.opensuse.org/pub/opensuse/repositories/server:/php/server_apache_SuSE_Linux_10.0/i586/
Previous Comments:
------------------------------------------------------------------------
[2006-09-15 11:04:06] tony2001@php.net
How did you build/install PHP?
Make sure you don't have any old libmysqlclient.so in your system.
------------------------------------------------------------------------
[2006-09-15 10:56:12] albertbrian at gmail dot com
Description:
------------
- Linux SuSE 10.0
- Apache 2.2.3
- PHP 5.1.6
- MySQL 5.0.24
I get this warning in /var/log/apache2/error_log whenever I
start/restart Apache2
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php5/extensions/mysqli.so' -
/usr/lib/php5/extensions/mysqli.so: undefined symbol:
mysql_set_character_set in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=38841&edit=1