ID: 38841
Comment by: judas dot iscariote at gmail dot com
Reported By: albertbrian at gmail dot com
Status: Assigned
Bug Type: MySQLi related
Operating System: OpenSuSE 10.0
PHP Version: 5.1.6
Assigned To: georg
New Comment:
Well.. I myself create those packages are u using, so next time drop
me a note if you found any problem with them.
this bug is likely to be bogus.
user says he is running mysql 5.0.24 but SUSE 10.0 do not include
mysql5, nor server_apache_SuSE_Linux_10 repository packages are linked
against mysql 5 client libraries.
Previous Comments:
------------------------------------------------------------------------
[2006-09-15 11:52:58] tony2001@php.net
Assigned to MySQL people.
------------------------------------------------------------------------
[2006-09-15 11:14:57] albertbrian at gmail dot com
Thank you for your reply.
I've checked libmysqlclient.so in system, and I find libmysqlclient.so
point to libmysqlclient.so.15.0.0
I installed PHP by using rpm packages at
http://ftp.opensuse.org/pub/opensuse/repositories/server:/php/server_apache_SuSE_Linux_10.0/i586/
------------------------------------------------------------------------
[2006-09-15 11:04:06] tony2001@php.net
How did you build/install PHP?
Make sure you don't have any old libmysqlclient.so in your system.
------------------------------------------------------------------------
[2006-09-15 10:56:12] albertbrian at gmail dot com
Description:
------------
- Linux SuSE 10.0
- Apache 2.2.3
- PHP 5.1.6
- MySQL 5.0.24
I get this warning in /var/log/apache2/error_log whenever I
start/restart Apache2
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php5/extensions/mysqli.so' -
/usr/lib/php5/extensions/mysqli.so: undefined symbol:
mysql_set_character_set in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=38841&edit=1