Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on

From: Date: Thu, 13 Jun 2002 02:15:52 +0000
Subject: Bug #13595 Updated: Solution for "PHP Fatal error: Unable to start session mm module in Unknown on
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10300@lists.php.net to get a copy of this message
ID: 13595 Updated by: supers@starblaze.2y.net Reported By: plafundum@yahoo.com Status: Analyzed Bug Type: Session related Operating System: Debian Sid PHP Version: 4.0.6 New Comment: I get fstat64(3, {st_mode=S_IFREG|0644, st_size=1748, ...}) = 0 unlink("/tmp/session_mm_apache0.sem") = -1 ENOENT (No such file or directory) before it dies, any idea? (using debian linux) Previous Comments: ------------------------------------------------------------------------ [2002-04-24 17:18:41] 2002@gabrielwicke.de Sorry, i forgot to mention my settings: session handler is 'files', location for those /tmp- my php.ini is completely unchanged from the defaults sessionwise. ------------------------------------------------------------------------ [2002-04-24 17:15:48] 2002@gabrielwicke.de I'm experiencing a similar problem after updating to php 4.1.0-104 (from the SUSE 8.0 Distro). Whenever i try to call php as a cgi ftp server i now get this: Content-type: text/html PHP Fatal error: Unable to start session mm module in Unknown on line 0 i did a locate .sem and it showed one file at /var/lib/httpd/mm.1257.sem. Deleting that didn't help. The ftp loader worked perfect with the previous version (4.0something), and the trouble with the new version appears only when calling php as cgi. Any ideas? ------------------------------------------------------------------------ [2002-03-07 15:08:30] matt@mystile.com Yes, I had the save path explicitly set to '/dev/null' in php.ini since I first installed version 4.0.5; I haven't been using sessions, so I wouldn't have noticed if sessions were not working. However, after the upgrade, I sure noticed something was wrong, since apache wouldn't start. As for why it was setup that way... I have the server setup so each virtual host uses its own 'tmp' directory, and as I recall, I didn't want PHP to store anything in '/tmp'. ------------------------------------------------------------------------ [2002-03-07 00:30:14] mfischer@php.net Ah .. interesting ... Did you set the save path explicitely to '/dev/null' ? (And if so, why?) All I know at the moment is that serveral session issues are adressed at the moment. Marking this as analyzed until one of our session gurus can answer this more accurat. ------------------------------------------------------------------------ [2002-03-06 19:50:16] matt@mystile.com Thanks to mfischer@php.net, I found the problem using strace. I had 'session.save_path' set to '/dev/null'. Why does 4.1.2 not handle this gracefully like 4.0.5, and is there any way to get a more helpful error message in this case? In case you're interested in the exact errors, I've included the errors from the strace below: unlink("/dev/null/session_mm_apache0.sem") = -1 ENOTDIR (Not a directory) open("/dev/null/session_mm_apache0.sem", O_RDWR|O_CREAT, 0600) = -1 ENOTDIR (Not a directory) unlink("/dev/null/session_mm_apache0.sem") = -1 ENOTDIR (Not a directory) ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/13595 -- Edit this bug report at http://bugs.php.net/?id=13595&edit=1

« previous php.bugs (#10300) next »