Bug #15688 Updated: undefined symbol:stat
| From: | michael at ettl dot at | Date: | Thu, 13 Jun 2002 08:25:13 +0000 |
| Subject: | Bug #15688 Updated: undefined symbol:stat | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-10310@lists.php.net to get a copy of this message | ||
ID: 15688
Updated by: michael@ettl.at
Reported By: wleyer@compuserve.com
Status: Duplicate
Bug Type: Informix related
Operating System: SuSe Linux 7.3
PHP Version: 4.1.1
New Comment:
the problem only occurs when configuring as dynamic module.
i built the php executable with
# ./configure --with-informix
and dumped my php-File containing some Informix-Selects on php
# ./php < test.php
and it worked fine.
Linux version: Suse 7.3
Informix cdsk version: 9.51UC1
httpd version: 1.3.24
php version: 4.2.1
Then i tried to compile php as static into apache - but this didn't
work with php 4.2.1 as i got the error
"libtool: link: only absolute run-paths are allowed" on linking.
So i took php 4.1.2 and compiled it into apache and it worked.
Previous Comments:
------------------------------------------------------------------------
[2002-05-25 09:14:29] derick@php.net
Dup of #13655
------------------------------------------------------------------------
[2002-04-25 05:10:18] isaac.hopley@no_spam.morton-fraser.com
I have constantly had similar problems. The only comination of
Platform I can successfully compile on is:
SuSe 7.2
PHP 4.06
Apache 1.3.19
Using the CSDK 2.70 UC1
Very annoying as I would like to be using the latest versions of all
these.
Anyone have a copy of CSDK I could have to try ??
------------------------------------------------------------------------
[2002-03-02 08:17:18] roland.wintgen@t-online.de
The problem is CSDK 2.70. Try getting the older version 2.60.
Unfortunately it is no more available on the website
"www.informix.com/evaluate". There has somethings changed between the
two versions which produces this error.
There was a discussion about this in comp.databases.informix about the
end of the year 2001. Take a look at:
http://dbforums.com/archive/40/2001/12/1/218803
------------------------------------------------------------------------
[2002-02-23 09:36:00] wleyer@compuserve.com
i can configure PHP4 with Informix as dynamic module without getting
errors. But when i try to start th Apache server i get the error
message
Cannot load /usr/lib/apache/libphp4.so into server:
opt/informix/lib/esql/libifgen.so: undefined symbol
/usr/sbin/apachectl start: httpd could not be started
configure:
./configure --with-config-file-path=/etc --with-apxs --with-informix
Linux version: Suse 7.3
Informix cdsk version: 9.51UC1
Make: version 3.79.1
gcc version: 2.95.3
flex version: 2.5.4
bison version: 1.28
httpd version: 1.3.20
I trying since several days to get it running, i have serched a lot of
sites for a solutiion, and tried out several changes in generating and
setting Variables but it's always the same.
Can the problem solved by PHP or is it a problem of the
Informix cdsk?
Thanks for any help.
Winfried
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=15688&edit=1