#39079 [NEW]: PHP 5.1.6 doesn't compile with MySQL 5.0.x and OpenSSL 0.9.8d
| From: | henrik at schack dot dk | Date: | Sat, 07 Oct 2006 19:08:38 +0000 |
| Subject: | #39079 [NEW]: PHP 5.1.6 doesn't compile with MySQL 5.0.x and OpenSSL 0.9.8d | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-103242@lists.php.net to get a copy of this message | ||
From: henrik at schack dot dk
Operating system: Rhel4
PHP version: 5.1.6
PHP Bug Type: Compile Failure
Bug description: PHP 5.1.6 doesn't compile with MySQL 5.0.x and OpenSSL 0.9.8d
Description:
------------
Compile fails with the following message:
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x54): In
function `CRYPTO_lock':
/home/mysqldev/rpm/BUILD/mysql-5.0.26/extra/yassl/taocrypt/src/misc.cpp:37:
multiple definition of `CRYPTO_lock'
/opt/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x224): first defined here
/usr/bin/ld: Warning: size of symbol `CRYPTO_lock' changed from 283 in
/opt/openssl/lib/libcrypto.a(cryptlib.o) to 7 in
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x5c): In
function `CRYPTO_add_lock':
/home/mysqldev/rpm/BUILD/mysql-5.0.26/extra/yassl/taocrypt/src/misc.cpp:38:
multiple definition of `CRYPTO_add_lock'
/opt/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x340): first defined here
/usr/bin/ld: Warning: size of symbol `CRYPTO_add_lock' changed from 98 in
/opt/openssl/lib/libcrypto.a(cryptlib.o) to 7 in
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
Reproduce code:
---------------
Configured withe the folowing statement:
./configure --with-mysql=/usr --with-mysqli
--with-apxs=/usr/local/apache/bin/apxs --enable-track-vars --with-gd
--with-xml --with-ttf --with-gmp --with-zlib-dir=/usr/lib
--with-jpeg-dir=/usr/lib --with-expat-dir=/usr --with-png-dir=/usr/lib
--with-xmlrpc --enable-exif --enable-ftp --with-mhash --with-mcrypt
--with-gettext --with-mbstring --with-iconv --enable-memory-limit
--with-dom=/usr/lib --enable-soap --with-xsl --with-curl
--with-curlwrappers --enable-dba --with-db4 --with-pdo-mysql
--without-pdo-sqlite --enable-mbstring --with-openssl=/opt/openssl
OpenSSL 0.9.8d
MySQL 5.0.26, did also try with 5.0.24 which gave a few more errors.
--
Edit bug report at http://bugs.php.net/?id=39079&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39079&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39079&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39079&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39079&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39079&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39079&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39079&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39079&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39079&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39079&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39079&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39079&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39079&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39079&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39079&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39079&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39079&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39079&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39079&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39079&r=mysqlcfg