#39079 [Opn->Bgs]: PHP 5.1.6 doesn't compile with MySQL 5.0.x and OpenSSL 0.9.8d
ID: 39079
Updated by: tony2001@php.net
Reported By: henrik at schack dot dk
-Status: Open
+Status: Bogus
Bug Type: Compile Failure
Operating System: Rhel4
PHP Version: 5.1.6
New Comment:
Not PHP problem, please report it to MySQL people.
Previous Comments:
------------------------------------------------------------------------
[2006-10-07 19:08:38] henrik at schack dot dk
Description:
------------
Compile fails with the following message:
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x54): In
function `CRYPTO_lock':
/home/mysqldev/rpm/BUILD/mysql-5.0.26/extra/yassl/taocrypt/src/misc.cpp:37:
multiple definition of `CRYPTO_lock'
/opt/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x224): first defined
here
/usr/bin/ld: Warning: size of symbol `CRYPTO_lock' changed from 283 in
/opt/openssl/lib/libcrypto.a(cryptlib.o) to 7 in
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)(.text+0x5c): In
function `CRYPTO_add_lock':
/home/mysqldev/rpm/BUILD/mysql-5.0.26/extra/yassl/taocrypt/src/misc.cpp:38:
multiple definition of `CRYPTO_add_lock'
/opt/openssl/lib/libcrypto.a(cryptlib.o)(.text+0x340): first defined
here
/usr/bin/ld: Warning: size of symbol `CRYPTO_add_lock' changed from 98
in /opt/openssl/lib/libcrypto.a(cryptlib.o) to 7 in
/usr/lib/mysql/libmysqlclient.a(libtaocrypt_la-misc.o)
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
Reproduce code:
---------------
Configured withe the folowing statement:
./configure --with-mysql=/usr --with-mysqli
--with-apxs=/usr/local/apache/bin/apxs --enable-track-vars --with-gd
--with-xml --with-ttf --with-gmp --with-zlib-dir=/usr/lib
--with-jpeg-dir=/usr/lib --with-expat-dir=/usr --with-png-dir=/usr/lib
--with-xmlrpc --enable-exif --enable-ftp --with-mhash --with-mcrypt
--with-gettext --with-mbstring --with-iconv --enable-memory-limit
--with-dom=/usr/lib --enable-soap --with-xsl --with-curl
--with-curlwrappers --enable-dba --with-db4 --with-pdo-mysql
--without-pdo-sqlite --enable-mbstring --with-openssl=/opt/openssl
OpenSSL 0.9.8d
MySQL 5.0.26, did also try with 5.0.24 which gave a few more errors.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39079&edit=1
Thread (2 messages)