Bug #17493 Updated: Undefined Symobl: pthread_getspecific when starting Apache

From: Date: Thu, 13 Jun 2002 13:49:36 +0000
Subject: Bug #17493 Updated: Undefined Symobl: pthread_getspecific when starting Apache
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10345@lists.php.net to get a copy of this message
ID: 17493 Updated by: sniper@php.net Reported By: thuresson@coe.tsuniv.edu -Status: Open +Status: Closed Bug Type: Apache2 related Operating System: FreeBSD 4.4 PHP Version: 4.0CVS-2002-05-28 New Comment: See bug: http://bugs.php.net/?id=14594 which has good explanation what the problem is and how to solve it. Previous Comments: ------------------------------------------------------------------------ [2002-05-28 15:57:03] thuresson@coe.tsuniv.edu Sorry for posting this under FreeBSD 4.1.1/PHP 4.2.1 I successfully compiled Apache 2.0.36/PHP 4.3.0 dev on RedHat 7.2 Apache ./configure --prefix=/usr/local/apache2 --enable-modules=most --enable-so PHP ./configure --prefix=/usr/local/php430 --enable-ftp --with-apxs2=/usr/local/apache2/bin/apxs httpd.conf LoadModule php4_module modules/libphp4.so AddType application/x-httpd-php .php I failed similar to previous comments when trying to install it the same way on FreeBSD 4.4 ./apachectl start Syntax error on line 230 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific" ./apachectl start: httpd could not be started ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=17493&edit=1

« previous php.bugs (#10345) next »