Bug #17493: Undefined Symobl: pthread_getspecific when starting Apache
| From: | thuresson at coe dot tsuniv dot edu | Date: | Tue, 28 May 2002 19:57:03 +0000 |
| Subject: | Bug #17493: Undefined Symobl: pthread_getspecific when starting Apache | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-8797@lists.php.net to get a copy of this message | ||
From: thuresson@coe.tsuniv.edu
Operating system: FreeBSD 4.4
PHP version: 4.0CVS-2002-05-28
PHP Bug Type: Apache2 related
Bug description: Undefined Symobl: pthread_getspecific when starting Apache
Sorry for posting this under FreeBSD 4.1.1/PHP 4.2.1
I successfully compiled Apache 2.0.36/PHP 4.3.0 dev on RedHat 7.2
Apache
./configure --prefix=/usr/local/apache2 --enable-modules=most
--enable-so
PHP
./configure --prefix=/usr/local/php430 --enable-ftp
--with-apxs2=/usr/local/apache2/bin/apxs
httpd.conf
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
I failed similar to previous comments when trying to install it the same
way on FreeBSD 4.4
./apachectl start
Syntax error on line 230 of
/usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into
server: /usr/local/apache2/modules/libphp4.so: Undefined
symbol "pthread_getspecific"
./apachectl start: httpd could not be started
--
Edit bug report at http://bugs.php.net/?id=17493&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=17493&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=17493&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=17493&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=17493&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=17493&r=support
Expected behavior: http://bugs.php.net/fix.php?id=17493&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=17493&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=17493&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=17493&r=globals