#39123 [Opn->Bgs]: upload_tmp_dir with trailing slash in open_basedir causes uploads to fail
| From: | iliaa@php.net | Date: | Wed, 11 Oct 2006 23:31:41 +0000 |
| Subject: | #39123 [Opn->Bgs]: upload_tmp_dir with trailing slash in open_basedir causes uploads to fail | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-103456@lists.php.net to get a copy of this message | ||
ID: 39123
Updated by: iliaa@php.net
Reported By: phpbugs at thequod dot de
-Status: Open
+Status: Bogus
Bug Type: Safe Mode/open_basedir
Operating System: Ubuntu Linux
PHP Version: 5CVS-2006-10-11 (CVS)
New Comment:
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
Standard process for validating open_basedir applies here.
Previous Comments:
------------------------------------------------------------------------
[2006-10-11 01:44:07] phpbugs at thequod dot de
Description:
------------
I have no upload_tmp_dir set, so it seems to use "/tmp".
I have added "/tmp/" to open_basedir (despite the fact
that this was not necessary before - see
http://bugs.php.net/38934).
Upload in PHP_5_2 fails with:
[11-Oct-2006 03:26:35] PHP Warning: Unknown: open_basedir
restriction in effect. File(/tmp) is not within the
allowed path(s):
(/web7/:/var/www/web7/:/tmp/:/var/www/usr/local/share/php/:/usr/local/share/php/)
in Unknown on line 0
[11-Oct-2006 03:26:35] PHP Warning: File upload error -
unable to create a temporary file in Unknown on line 0
This is a regression to PHP_5_1, where it works like this!
Setting upload_tmp_dir=/tmp/ (with ending slash) fixes it
also for PHP_5_2.
Reproduce code:
---------------
Any upload form, there are two in the other bug refered above.
Expected result:
----------------
Upload works.
Actual result:
--------------
Upload does not work.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39123&edit=1