ID: 39123
User updated by: phpbugs at thequod dot de
Reported By: phpbugs at thequod dot de
-Status: Bogus
+Status: Open
Bug Type: Safe Mode/open_basedir
Operating System: Ubuntu Linux
PHP Version: 5CVS-2006-10-11 (CVS)
New Comment:
Yes, setting upload_tmp_dir explicitly does not cause the
problem (anymore).
But still, because the default of upload_tmp_dir is empty,
it should not bail out when detecting the upload_tmp_dir
setting.
Manually setting upload_tmp_dir to "/tmp" (without
trailing slash) allows uploading, but leaving it unset,
errors out with:
"""
PHP Warning: Unknown: open_basedir restriction in effect.
File(/tmp) is not within the allowed path(s): (/X/:/tmp/)
in Unknown on line 0
PHP Warning: File upload error - unable to create a
temporary file in Unknown on line 0
"""
To me it looks like the error gets triggered while
determining the default upload_tmp_dir setting.
I consider setting "upload_tmp_dir" explicitly as a
work-around currently, but it should not be necessary for
upgrading to 5.2 IMHO.
Previous Comments:
------------------------------------------------------------------------
[2006-10-13 02:21:22] iliaa@php.net
Make sure your upload_tmp_dir is set and then it'll work.
------------------------------------------------------------------------
[2006-10-12 15:28:12] phpbugs at thequod dot de
While at it, please reconsider also
http://bugs.php.net/38934 and at least document since when
then upload_tmp_dir is needed in open_basedir.
------------------------------------------------------------------------
[2006-10-12 04:05:26] judas dot iscariote at gmail dot com
Ilia :
Can u reconsider this ? this is a BC break, and Im sure gazillions or
webserver config files will break with this change.
------------------------------------------------------------------------
[2006-10-12 02:26:56] phpbugs at thequod dot de
I've changed the summary.
Long version:
Default for "upload_tmp_dir" has changed from "/tmp/"
to "/tmp" and uploads now fail with open_base_dir="/tmp/"!
This is a regression!
If I use "/tmp/" in open_base_dir, I expect it to also
handle accesses to the "/tmp" directory itself!
(all apart the fact that it's ridiculous to manually have
to add upload_tmp_dir to open_basedir for uploads to work)
------------------------------------------------------------------------
[2006-10-11 23:31:40] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
Standard process for validating open_basedir applies here.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/39123--
Edit this bug report at http://bugs.php.net/?id=39123&edit=1