#39200 [NEW]: Loading libphp5.so; undefined symbol: zend_qsort
| From: | phpbug at sconex dot com | Date: | Thu, 19 Oct 2006 16:03:55 +0000 |
| Subject: | #39200 [NEW]: Loading libphp5.so; undefined symbol: zend_qsort | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-103742@lists.php.net to get a copy of this message | ||
From: phpbug at sconex dot com
Operating system: Red Hat EL 4
PHP version: 5.1.6
PHP Bug Type: Apache2 related
Bug description: Loading libphp5.so; undefined symbol: zend_qsort
Description:
------------
Configured with --enable-mbstring --with-mysql --with-libdir=lib64
--with-apxs2, also tried with just --with-apxs2. Upon restarting apache
this error message appears:
apachectl: Configuration syntax error, will not run "graceful":
Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp5.so into server:
/etc/httpd/modules/libphp5.so: undefined symbol: zend_qsort
Note: 5.2.0RC6 will have no trouble loading into apache.
Note: PHP 4.3.9 is currently on the system as well. (rpm install from
up2date)
Reproduce code:
---------------
./configure --enable-mbstring --with-mysql --with-apxs2=/usr/sbin/apxs
--with-libdir=lib64
make && make install && make install-sapi
apachectl graceful
Expected result:
----------------
Apache reloads and php5 is enabled.
Actual result:
--------------
apachectl: Configuration syntax error, will not run "graceful":
Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /etc/httpd/modules/libphp5.so into server:
/etc/httpd/modules/libphp5.so: undefined symbol: zend_qsort
--
Edit bug report at http://bugs.php.net/?id=39200&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39200&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39200&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39200&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39200&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39200&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39200&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39200&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39200&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39200&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39200&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39200&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39200&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39200&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39200&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39200&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39200&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39200&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39200&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39200&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39200&r=mysqlcfg