#39200 [Opn->Csd]: Loading libphp5.so; undefined symbol: zend_qsort

From: Date: Thu, 19 Oct 2006 16:14:57 +0000
Subject: #39200 [Opn->Csd]: Loading libphp5.so; undefined symbol: zend_qsort
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-103745@lists.php.net to get a copy of this message
ID: 39200 Updated by: tony2001@php.net Reported By: phpbug at sconex dot com -Status: Open +Status: Closed Bug Type: Apache2 related Operating System: Red Hat EL 4 PHP Version: 5.1.6 New Comment: >Note: 5.2.0RC6 will have no trouble loading into apache. Then it's fixed. Thanks for letting us know. Previous Comments: ------------------------------------------------------------------------ [2006-10-19 16:03:55] phpbug at sconex dot com Description: ------------ Configured with --enable-mbstring --with-mysql --with-libdir=lib64 --with-apxs2, also tried with just --with-apxs2. Upon restarting apache this error message appears: apachectl: Configuration syntax error, will not run "graceful": Syntax error on line 6 of /etc/httpd/conf.d/php.conf: Cannot load /etc/httpd/modules/libphp5.so into server: /etc/httpd/modules/libphp5.so: undefined symbol: zend_qsort Note: 5.2.0RC6 will have no trouble loading into apache. Note: PHP 4.3.9 is currently on the system as well. (rpm install from up2date) Reproduce code: --------------- ./configure --enable-mbstring --with-mysql --with-apxs2=/usr/sbin/apxs --with-libdir=lib64 make && make install && make install-sapi apachectl graceful Expected result: ---------------- Apache reloads and php5 is enabled. Actual result: -------------- apachectl: Configuration syntax error, will not run "graceful": Syntax error on line 6 of /etc/httpd/conf.d/php.conf: Cannot load /etc/httpd/modules/libphp5.so into server: /etc/httpd/modules/libphp5.so: undefined symbol: zend_qsort ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=39200&edit=1

« previous php.bugs (#103745) next »