#39233 [NEW]: Windows MSI installer cannot configure Apache 2.2
| From: | matt at genesi-usa dot com | Date: | Mon, 23 Oct 2006 09:49:38 +0000 |
| Subject: | #39233 [NEW]: Windows MSI installer cannot configure Apache 2.2 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-103897@lists.php.net to get a copy of this message | ||
From: matt at genesi-usa dot com
Operating system: Windows XP Home SP2
PHP version: 5.2.0RC5
PHP Bug Type: Unknown/Other Function
Bug description: Windows MSI installer cannot configure Apache 2.2
Description:
------------
The apacheconfig.php script bundled with the new MSI installer breaks;
when selecting a directory from the installer, a semicolon is appended to
the path. When it is passed to the script, the script builds configuration
filenames as:
C:\Program Files\Apache Software Foundation\Apache2.2\conf\;httpd.conf
Fixing that error, it fails to backup the httpd.conf and mime.types files
before editing.
Reproduce code:
---------------
Select Apache 2.2 module from the list, pick a directory.
I fixed it by changing:
$foldername = str_replace(array('"', ';\\'),
array('','\\'), $argv[2]);
Also even though I run as Administrator for the purposes of installing,
the two backup checks fail for some reason. I didn't look into this so I
just commented that entire elseif statement out for both files (I don't
need a backup it was a fresh Apache 2.2 install with the default
configuration file)
--
Edit bug report at http://bugs.php.net/?id=39233&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39233&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39233&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39233&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39233&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39233&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39233&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39233&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39233&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39233&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39233&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39233&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39233&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39233&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39233&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39233&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39233&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39233&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39233&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39233&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39233&r=mysqlcfg