#39233 [Asn->Csd]: Windows MSI installer cannot configure Apache 2.2

From: Date: Mon, 30 Oct 2006 12:51:34 +0000
Subject: #39233 [Asn->Csd]: Windows MSI installer cannot configure Apache 2.2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-104176@lists.php.net to get a copy of this message
ID: 39233 Updated by: jmertic@php.net Reported By: matt at genesi-usa dot com -Status: Assigned +Status: Closed Bug Type: Unknown/Other Function Operating System: Windows XP Home SP2 PHP Version: 5.2.0RC5 Assigned To: jmertic New Comment: I cannot reproduce this at all. If it's a permissions issue then I would double check that the current user has full access to that file and folder. Previous Comments: ------------------------------------------------------------------------ [2006-10-25 17:51:18] matt at genesi-usa dot com the (!copy(httpd.conf, httpd.conf.bak)) check still fails here for some reason (permission denied?) ------------------------------------------------------------------------ [2006-10-24 12:10:20] jmertic@php.net Added removal of ';' in $foldername, and tweaked check for file ( using is_file() instead of file() ) now in CVS. ------------------------------------------------------------------------ [2006-10-23 09:49:38] matt at genesi-usa dot com Description: ------------ The apacheconfig.php script bundled with the new MSI installer breaks; when selecting a directory from the installer, a semicolon is appended to the path. When it is passed to the script, the script builds configuration filenames as: C:\Program Files\Apache Software Foundation\Apache2.2\conf\;httpd.conf Fixing that error, it fails to backup the httpd.conf and mime.types files before editing. Reproduce code: --------------- Select Apache 2.2 module from the list, pick a directory. I fixed it by changing: $foldername = str_replace(array('"', ';\\'), array('','\\'), $argv[2]); Also even though I run as Administrator for the purposes of installing, the two backup checks fail for some reason. I didn't look into this so I just commented that entire elseif statement out for both files (I don't need a backup it was a fresh Apache 2.2 install with the default configuration file) ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=39233&edit=1

« previous php.bugs (#104176) next »