#39326 [Opn]: dbase_open can't open database
ID: 39326
User updated by: jabc at moz dot com dot mx
Reported By: jabc at moz dot com dot mx
Status: Open
Bug Type: dBase related
Operating System: FreeBSD 6.2-PRERELEASE
PHP Version: 5.1.6
New Comment:
we determine that the problem was the type of fields, we have four
fields with type 'date time' and when we change to type 'date' it
work.
But in version php4.4 it work fine with this type of fields.
try to test with this database that contain the four fields type 'date
time' and try to modify this fields to type 'date' for verify that work
it
http://148.223.129.153/soporte/complete.zip
thanks
Previous Comments:
------------------------------------------------------------------------
[2006-10-31 22:05:47] jabc at moz dot com dot mx
Description:
------------
when I try to open an database with more than 150 fields can't open it.
only If I delete fields under 150 can do it.
on version 4.4 it work very fine.
the error say: unable to open database
of course STCTRL21.DBF exist and have all permissions.
Reproduce code:
---------------
$dbi = dbase_open("/reco/RECO2005/TRAFICO/DATA/STCTRL21.DBF", 0);
if ($dbi === false)
print "unable to open database";
Expected result:
----------------
No errors and the database opened.
Actual result:
--------------
unable to open database
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39326&edit=1
Thread (3 messages)