#39326 [Opn->Bgs]: dbase_open can't open database
| From: | tony2001@php.net | Date: | Wed, 08 Nov 2006 14:21:53 +0000 |
| Subject: | #39326 [Opn->Bgs]: dbase_open can't open database | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-104594@lists.php.net to get a copy of this message | ||
ID: 39326
Updated by: tony2001@php.net
Reported By: jabc at moz dot com dot mx
-Status: Open
+Status: Bogus
Bug Type: dBase related
Operating System: FreeBSD 6.2-PRERELEASE
PHP Version: 5.1.6
New Comment:
T fields are not supported.
The list of supported field types can be found here:
http://php.net/dbase
Previous Comments:
------------------------------------------------------------------------
[2006-10-31 23:06:54] jabc at moz dot com dot mx
we determine that the problem was the type of fields, we have four
fields with type 'date time' and when we change to type 'date' it
work.
But in version php4.4 it work fine with this type of fields.
try to test with this database that contain the four fields type 'date
time' and try to modify this fields to type 'date' for verify that work
it
http://148.223.129.153/soporte/complete.zip
thanks
------------------------------------------------------------------------
[2006-10-31 22:05:47] jabc at moz dot com dot mx
Description:
------------
when I try to open an database with more than 150 fields can't open it.
only If I delete fields under 150 can do it.
on version 4.4 it work very fine.
the error say: unable to open database
of course STCTRL21.DBF exist and have all permissions.
Reproduce code:
---------------
$dbi = dbase_open("/reco/RECO2005/TRAFICO/DATA/STCTRL21.DBF", 0);
if ($dbi === false)
print "unable to open database";
Expected result:
----------------
No errors and the database opened.
Actual result:
--------------
unable to open database
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39326&edit=1