#39376 [Com]: Unable to load dynamic library 'ext/php_oci8.dll'
| From: | crescentfreshpot at yahoo dot com | Date: | Sat, 04 Nov 2006 18:42:37 +0000 |
| Subject: | #39376 [Com]: Unable to load dynamic library 'ext/php_oci8.dll' | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-104409@lists.php.net to get a copy of this message | ||
ID: 39376
Comment by: crescentfreshpot at yahoo dot com
Reported By: automap at gmail dot com
Status: Open
Bug Type: OCI8 related
Operating System: WindowsXP
PHP Version: 5.2.0
New Comment:
You need oracle instant client installed. See bug #39360
Previous Comments:
------------------------------------------------------------------------
[2006-11-04 12:09:06] automap at gmail dot com
Description:
------------
after I upgraded the Apache from 2.0.59 to 2.2.3
then I downloaded php5.2.0 to replace the original php5.0.5
but when I start apache, error log shows as below:
Unable to load dynamic library 'C:/php52/ext/php_oci8.dll' -
\xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xb3\xcc\xd0\xf2\xa1\xa3\r\n
in Unknown on line 0
Reproduce code:
---------------
the error log shows that the php_oci8.dll is not loaded when Apache is
started
my oracle client version is 9.2.0.1
it's good to load oci8 dll before I upgrade
because I upgrded php and apache , so I'm not sure whether it's a
problem of php, either inside apache
Expected result:
----------------
I need to load oci8 into the apache ,so I can connect my oracle db
Actual result:
--------------
now the oci8 dll can't be loaded.is it the problem of php5.2.0?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39376&edit=1