#39376 [Opn->Csd]: Unable to load Chinese characters from oci8
| From: | automap at gmail dot com | Date: | Mon, 06 Nov 2006 13:43:41 +0000 |
| Subject: | #39376 [Opn->Csd]: Unable to load Chinese characters from oci8 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-104465@lists.php.net to get a copy of this message | ||
ID: 39376
User updated by: automap at gmail dot com
Reported By: automap at gmail dot com
-Status: Open
+Status: Closed
Bug Type: OCI8 related
Operating System: WindowsXP
PHP Version: 5.2.0
New Comment:
problem resolved!
oci_connect() function should take the fourth parameter, which
indicates the characterset, for example:
oci_connect( $username, $password ,$db, 'ZHS16GBK');
Thanks to all
Previous Comments:
------------------------------------------------------------------------
[2006-11-06 08:09:06] automap at gmail dot com
Thanks to crescentfreshpot@yahoo.com
the problem "Unable to load dynamic library " was resolved.
but a new one occured:
when I fetch data from remote oracle db, I get the Chinese data in '?',
while the Eglish and numeric characterset is still ok.
I have thought that it's due to the parameter 'xLNS_LANG',but I have
changed many possible configure to the xLNS_LANG or NLS_LANG , NO
effect.
Why?
------------------------------------------------------------------------
[2006-11-05 15:28:12] jhtpeter at gmail dot com
I get the same problem.
My environment is: Windows 2003, Oracle9i Server, PHP 5.2
I installed oracle instant client and set these env variables:
PATH=C:\instantclient;...
TNS_ADMIN=C:\instantclient
LD_LIBRARY_PATH=C:\instantclient
and also edit registry as BUG#39096 instructions:
rename NLS_LANG TO xLNS_LANG
At last, apache logs report:
unable to load php_oci8.dll
It seem to if Oracle Server installed, PHP cannot use instant client as
the same machine?
------------------------------------------------------------------------
[2006-11-04 18:42:36] crescentfreshpot at yahoo dot com
You need oracle instant client installed. See bug #39360
------------------------------------------------------------------------
[2006-11-04 12:09:06] automap at gmail dot com
Description:
------------
after I upgraded the Apache from 2.0.59 to 2.2.3
then I downloaded php5.2.0 to replace the original php5.0.5
but when I start apache, error log shows as below:
Unable to load dynamic library 'C:/php52/ext/php_oci8.dll' -
\xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xb3\xcc\xd0\xf2\xa1\xa3\r\n
in Unknown on line 0
Reproduce code:
---------------
the error log shows that the php_oci8.dll is not loaded when Apache is
started
my oracle client version is 9.2.0.1
it's good to load oci8 dll before I upgrade
because I upgrded php and apache , so I'm not sure whether it's a
problem of php, either inside apache
Expected result:
----------------
I need to load oci8 into the apache ,so I can connect my oracle db
Actual result:
--------------
now the oci8 dll can't be loaded.is it the problem of php5.2.0?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39376&edit=1