#39513 [NEW]: URL file-access is disabled when allow_url_fopen = On
| From: | scott at html dot info | Date: | Tue, 14 Nov 2006 18:39:05 +0000 |
| Subject: | #39513 [NEW]: URL file-access is disabled when allow_url_fopen = On | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-104972@lists.php.net to get a copy of this message | ||
From: scott at html dot info
Operating system: RHEL 4.4 64-bit
PHP version: 5.2.0
PHP Bug Type: Filesystem function related
Bug description: URL file-access is disabled when allow_url_fopen = On
Description:
------------
allow_url_fopen is On in php.ini, phpinfo(); shows it as On, but scripts
are broke since the 5.1 -> 5.2 upgrade.
Reproduce code:
---------------
<?php
include "http://www.google.com";
?>
Actual result:
--------------
Warning: include() [function.include]: URL file-access is disabled in the
server configuration in /home/.../public_html/test1.php on line 2
Warning: include(http://www.google.com) [function.include]: failed to open
stream: no suitable wrapper could be found in
/home/.../public_html/test1.php on line 2
Warning: include() [function.include]: Failed opening
'http://www.google.com' for inclusion
(include_path='.:/usr/local/lib/php') in /home/.../public_html/test1.php
on line 2
--
Edit bug report at http://bugs.php.net/?id=39513&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39513&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39513&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39513&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39513&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39513&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39513&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39513&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39513&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39513&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39513&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39513&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39513&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39513&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39513&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39513&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39513&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39513&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39513&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39513&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39513&r=mysqlcfg