#39513 [Bgs]: URL file-access is disabled when allow_url_fopen = On

From: Date: Tue, 14 Nov 2006 18:49:33 +0000
Subject: #39513 [Bgs]: URL file-access is disabled when allow_url_fopen = On
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-104975@lists.php.net to get a copy of this message
ID: 39513 User updated by: scott at html dot info Reported By: scott at html dot info Status: Bogus Bug Type: Filesystem function related Operating System: RHEL 4.4 64-bit PHP Version: 5.2.0 New Comment: Oh thanks, that I missed. I looked at the docs but didn't see anything. Previous Comments: ------------------------------------------------------------------------ [2006-11-14 18:47:35] tony2001@php.net Set allow_url_include to On. See more details in README.UPDATE_5_2. ------------------------------------------------------------------------ [2006-11-14 18:39:05] scott at html dot info Description: ------------ allow_url_fopen is On in php.ini, phpinfo(); shows it as On, but scripts are broke since the 5.1 -> 5.2 upgrade. Reproduce code: --------------- <?php include "http://www.google.com"; ?> Actual result: -------------- Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/.../public_html/test1.php on line 2 Warning: include(http://www.google.com) [function.include]: failed to open stream: no suitable wrapper could be found in /home/.../public_html/test1.php on line 2 Warning: include() [function.include]: Failed opening 'http://www.google.com' for inclusion (include_path='.:/usr/local/lib/php') in /home/.../public_html/test1.php on line 2 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=39513&edit=1

« previous php.bugs (#104975) next »