#39516 [Opn->Fbk]: Unable to load dynamic library '/usr/lib/php/modules/informix.so'

From: Date: Tue, 14 Nov 2006 22:48:03 +0000
Subject: #39516 [Opn->Fbk]: Unable to load dynamic library '/usr/lib/php/modules/informix.so'
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-104982@lists.php.net to get a copy of this message
ID: 39516 Updated by: tony2001@php.net Reported By: ggmensajes at yahoo dot es -Status: Open +Status: Feedback Bug Type: Informix related Operating System: Linux Fedora Core 5 PHP Version: 5.2.0 New Comment: Plese make sure ld knows where to look for the Informix libs: ldd /usr/lib/php/modules/informix.so Previous Comments: ------------------------------------------------------------------------ [2006-11-14 22:42:45] ggmensajes at yahoo dot es Description: ------------ 1) There is no script executed yet. Error was triggered at startup 2) ./configure --with-informix=shared,/opt/informix 3) Procedure: - Generated module produced after make command (informix.so) was copied into /usr/lib/php/modules - An informix.ini file was created in /etc/php.d 4) Apache reinitialized (with informix environment vars included) and there was no informix connection available Expected result: ---------------- Informix connection available Actual result: -------------- PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/informix.so' - /opt/informix/lib/esql/libifos.so: undefined symbol: ifx_checkAPI in Unknown on line 0 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=39516&edit=1

« previous php.bugs (#104982) next »