#39516 [Opn->Fbk]: Unable to load dynamic library '/usr/lib/php/modules/informix.so'
| From: | tony2001@php.net | Date: | Wed, 15 Nov 2006 19:56:19 +0000 |
| Subject: | #39516 [Opn->Fbk]: Unable to load dynamic library '/usr/lib/php/modules/informix.so' | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-105034@lists.php.net to get a copy of this message | ||
ID: 39516
Updated by: tony2001@php.net
Reported By: ggmensajes at yahoo dot es
-Status: Open
+Status: Feedback
Bug Type: Informix related
Operating System: Linux Fedora Core 5
PHP Version: 5.2.0
New Comment:
And
ldconfig -p | grep informix, please.
Previous Comments:
------------------------------------------------------------------------
[2006-11-15 19:47:24] ggmensajes at yahoo dot es
This is the ldd result:
linux-gate.so.1 => (0x00a24000)
libifsql.so => /opt/informix/lib/esql/libifsql.so 0x00cbe000)
libifasf.so => /opt/informix/lib/libifasf.so (0x0098e000)
libifgen.so => /opt/informix/lib/esql/libifgen.so (0x00faa000)
libthcli.so => /opt/informix/lib/esql/libthcli.so (0x00d86000)
libifos.so => /opt/informix/lib/esql/libifos.so (0x00196000)
libifgls.so => /opt/informix/lib/esql/libifgls.so (0x00c7a000)
libdl.so.2 => /lib/libdl.so.2 (0x00aed000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x0072a000)
libifglx.so => /opt/informix/lib/esql/libifglx.so (0x00a67000)
libc.so.6 => /lib/libc.so.6 (0x003e9000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00164000)
libm.so.6 => /lib/libm.so.6 (0x00111000)
/lib/ld-linux.so.2 (0x009ce000)
Actually libifos.so is in /opt/informix/lib/esql directory
My installed Informix csdk version is:
csdk-2.90.UC4-1
Thanks
------------------------------------------------------------------------
[2006-11-14 22:48:03] tony2001@php.net
Plese make sure ld knows where to look for the Informix libs:
ldd /usr/lib/php/modules/informix.so
------------------------------------------------------------------------
[2006-11-14 22:42:45] ggmensajes at yahoo dot es
Description:
------------
1) There is no script executed yet. Error was triggered at startup
2) ./configure --with-informix=shared,/opt/informix
3) Procedure:
- Generated module produced after make command (informix.so) was copied
into /usr/lib/php/modules
- An informix.ini file was created in /etc/php.d
4) Apache reinitialized (with informix environment vars included) and
there was no informix connection available
Expected result:
----------------
Informix connection available
Actual result:
--------------
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/lib/php/modules/informix.so' - /opt/informix/lib/esql/libifos.so:
undefined symbol: ifx_checkAPI in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39516&edit=1