#39752 [NEW]: Can't start Apache2 due to libphp5.so error.
| From: | matt dot selph at gmail dot com | Date: | Wed, 06 Dec 2006 13:19:58 +0000 |
| Subject: | #39752 [NEW]: Can't start Apache2 due to libphp5.so error. | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-105994@lists.php.net to get a copy of this message | ||
From: matt dot selph at gmail dot com
Operating system: Suse 9.3
PHP version: 5.2.0
PHP Bug Type: Apache2 related
Bug description: Can't start Apache2 due to libphp5.so error.
Description:
------------
Cannot start Apache 2.2.3 after I compiled and installed php 5.2.0. I get
an error regarding libphp5.so and an undefined sqlite3 symbol.
Reproduce code:
---------------
Apache 2.2.3 configuration: ./configure --enable-so
PHP 5.2.0 configuration: ./configure --prefix=/usr/local/php5
--with-apxs2=/usr/local/apache2/bin/apxs --enable-xml --with-gd
--with-gettext --with-xml --with-zlib-dir=/usr/local/php-5.2.0/ext/zlib
--with-jpeg-dir
Error message: ./apachectl -k start
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server:
/usr/local/apache2/modules/libphp5.so: undefined symbol:
sqlite3ExprDelete
Expected result:
----------------
Expected Apache to start with no errors.
Actual result:
--------------
Got the following error:
./apachectl -k start
httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server:
/usr/local/apache2/modules/libphp5.so: undefined symbol:
sqlite3ExprDelete
Also a ps -ef | grep httpd showed no web server daemons running.
--
Edit bug report at http://bugs.php.net/?id=39752&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39752&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39752&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39752&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39752&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39752&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39752&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39752&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39752&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39752&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39752&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39752&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39752&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39752&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39752&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39752&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39752&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39752&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39752&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39752&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39752&r=mysqlcfg