#39752 [Opn->Fbk]: Can't start Apache2 due to libphp5.so error.

From: Date: Wed, 06 Dec 2006 13:25:16 +0000
Subject: #39752 [Opn->Fbk]: Can't start Apache2 due to libphp5.so error.
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-105995@lists.php.net to get a copy of this message
ID: 39752 Updated by: tony2001@php.net Reported By: matt dot selph at gmail dot com -Status: Open +Status: Feedback Bug Type: Apache2 related Operating System: Suse 9.3 PHP Version: 5.2.0 New Comment: make clean? Previous Comments: ------------------------------------------------------------------------ [2006-12-06 13:19:58] matt dot selph at gmail dot com Description: ------------ Cannot start Apache 2.2.3 after I compiled and installed php 5.2.0. I get an error regarding libphp5.so and an undefined sqlite3 symbol. Reproduce code: --------------- Apache 2.2.3 configuration: ./configure --enable-so PHP 5.2.0 configuration: ./configure --prefix=/usr/local/php5 --with-apxs2=/usr/local/apache2/bin/apxs --enable-xml --with-gd --with-gettext --with-xml --with-zlib-dir=/usr/local/php-5.2.0/ext/zlib --with-jpeg-dir Error message: ./apachectl -k start httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: sqlite3ExprDelete Expected result: ---------------- Expected Apache to start with no errors. Actual result: -------------- Got the following error: ./apachectl -k start httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: sqlite3ExprDelete Also a ps -ef | grep httpd showed no web server daemons running. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=39752&edit=1

« previous php.bugs (#105995) next »