#39926 [NEW]: Unalbe to load php mdule due to unresolve symbol in libaio_raw.so
| From: | tatireddyv at coned dot com | Date: | Thu, 21 Dec 2006 22:44:22 +0000 |
| Subject: | #39926 [NEW]: Unalbe to load php mdule due to unresolve symbol in libaio_raw.so | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-106759@lists.php.net to get a copy of this message | ||
From: tatireddyv at coned dot com
Operating system: Tru64(OSF1 V5.1 2650 alpha)
PHP version: 5.2.0
PHP Bug Type: Dynamic loading
Bug description: Unalbe to load php mdule due to unresolve symbol in libaio_raw.so
Description:
------------
Trying to start Apache(Version 2.0.59) with Php5.2 on Tru64 Unix( aka
OSF1..) to acess Oracle( version 10.1) but loader is throwing an error on
libaio_raw.so like below. Anyone has experiences with aio_raw.so library,
i know some of Oracle shared objects has dependency on this library, So
trying to find a way to get out from this error?. Already raised a case
with HP.
1)Apache Log...
[Fri Dec 15 10:52:25 2006] [notice] caught SIGTERM, shutting down
Syntax error on line 232 of /omega/apache/conf/httpd.conf:
Cannot load /omega/apache/modules/libphp5.so into server: dlopen:
libaio_raw.so: symbol "aio_prefork" unresolved
2)Php configuration options
a) ./configure --with-apxs2=/omega/apache/bin/apxs \
--prefix=/omega/apache/php5.2 \
--with-config-file- \
path=/omega/apache/php5.2/config \
--with-oci8=$ORACLE_HOME
--with-libxml-dir=/omega/apache/libxml2-2.6.11
3)PHP Version
PHP 5.2.0 (cli) (built: Dec 15 2006 11:52:19)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
--
Edit bug report at http://bugs.php.net/?id=39926&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39926&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39926&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39926&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39926&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39926&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39926&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39926&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39926&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39926&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39926&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39926&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39926&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39926&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39926&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39926&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39926&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39926&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39926&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39926&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39926&r=mysqlcfg