#39926 [Opn->Bgs]: Unalbe to load php mdule due to unresolve symbol in libaio_raw.so
| From: | tony2001@php.net | Date: | Thu, 21 Dec 2006 22:53:35 +0000 |
| Subject: | #39926 [Opn->Bgs]: Unalbe to load php mdule due to unresolve symbol in libaio_raw.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-106760@lists.php.net to get a copy of this message | ||
ID: 39926
Updated by: tony2001@php.net
Reported By: tatireddyv at coned dot com
-Status: Open
+Status: Bogus
Bug Type: Dynamic loading
Operating System: Tru64(OSF1 V5.1 2650 alpha)
PHP Version: 5.2.0
New Comment:
Dup of bug #37365, not PHP problem.
Previous Comments:
------------------------------------------------------------------------
[2006-12-21 22:44:21] tatireddyv at coned dot com
Description:
------------
Trying to start Apache(Version 2.0.59) with Php5.2 on Tru64 Unix( aka
OSF1..) to acess Oracle( version 10.1) but loader is throwing an error
on libaio_raw.so like below. Anyone has experiences with aio_raw.so
library, i know some of Oracle shared objects has dependency on this
library, So trying to find a way to get out from this error?. Already
raised a case with HP.
1)Apache Log...
[Fri Dec 15 10:52:25 2006] [notice] caught SIGTERM, shutting down
Syntax error on line 232 of /omega/apache/conf/httpd.conf:
Cannot load /omega/apache/modules/libphp5.so into server: dlopen:
libaio_raw.so: symbol "aio_prefork" unresolved
2)Php configuration options
a) ./configure --with-apxs2=/omega/apache/bin/apxs \
--prefix=/omega/apache/php5.2 \
--with-config-file- \
path=/omega/apache/php5.2/config \
--with-oci8=$ORACLE_HOME
--with-libxml-dir=/omega/apache/libxml2-2.6.11
3)PHP Version
PHP 5.2.0 (cli) (built: Dec 15 2006 11:52:19)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39926&edit=1