#39936 [NEW]: Some extensions loaded while others are ignored
| From: | asbo at iserv dot net | Date: | Sat, 23 Dec 2006 09:22:22 +0000 |
| Subject: | #39936 [NEW]: Some extensions loaded while others are ignored | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-106819@lists.php.net to get a copy of this message | ||
From: asbo at iserv dot net
Operating system: Windows XP Professional SP2
PHP version: 5.2.0
PHP Bug Type: Apache2 related
Bug description: Some extensions loaded while others are ignored
Description:
------------
Note: The
Apache2 related may or not may be entirely accurate; I don't
know the scope of the issue.
After a recent re-install, I went to re-setup my Apache/PHP development
server, and ran into problems with getting extensions to load properly.
The following is set in my php.ini:
display_startup_errors = On
extension_dir = "./"
extension=php_curl.dll
extension=php_mbstring.dll
extension=php_mysql.dll
My path to php is d:\program files\apache2\php5.
My PATH environment variable has d:\program files\apache2\php5 set in
it.
PHP is being run as a module of Apache2.
I've tried numerous variations of extension_dir:
.
"."
.\
".\"
.\\
".\\"
./
"./"
d:\program files\apache2\php5\ext
"d:\program files\apache2\php5\ext"
d:\program files\apache2\php5\ext\
"d:\program files\apache2\php5\ext\"
d:\\program files\\apache2\\php5\\ext
"d:\\program files\\apache2\\php5\\ext"
d:\\program files\\apache2\\php5\\ext\\
"d:\\program files\\apache2\\php5\\ext\\"
d:/program files/apache2/php5/ext
"d:/program files/apache2/php5/ext"
d:/program files/apache2/php5/ext/
"d:/program files/apache2/php5/ext/"
Expected result:
----------------
The three extensions -- MBString, cURL, and MySQL -- load properly.
Actual result:
--------------
When Apache2 starts, I receive the following messageboxes:
"Warning"
PHP Startup: Unable to load dynamic library '*php_curl.dll' - The
specified module could not be found.
"Warning"
PHP Startup: Unable to load dynamic library '*php_mysql.dll' - The
specified module could not be found.
"Warning"
PHP Startup: Unable to load dynamic library '*php_curl.dll' - The
specified module could not be found.
"Warning"
PHP Startup: Unable to load dynamic library '*php_mysql.dll' - The
specified module could not be found.
* Represents any of the previously mentioned path variations.
Yes, I get each messagebox twice. So, cURL and MySQL are failing to load
-- but MBString isn't?? I've verified there is only one copy of
php_mbstring.dll on my computer -- the one in the /ext directory, right
next to php_curl.dll and php_mysql.dll.
phpinfo() confirms that mbstring is loaded, but cURL/MySQL are not.
--
Edit bug report at http://bugs.php.net/?id=39936&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=39936&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=39936&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=39936&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=39936&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=39936&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=39936&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=39936&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=39936&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=39936&r=support
Expected behavior: http://bugs.php.net/fix.php?id=39936&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=39936&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=39936&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=39936&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=39936&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=39936&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=39936&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=39936&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=39936&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=39936&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=39936&r=mysqlcfg