#39936 [Bgs]: Some extensions loaded while others are ignored
| From: | asbo at iserv dot net | Date: | Sat, 23 Dec 2006 16:09:13 +0000 |
| Subject: | #39936 [Bgs]: Some extensions loaded while others are ignored | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-106824@lists.php.net to get a copy of this message | ||
ID: 39936
User updated by: asbo at iserv dot net
Reported By: asbo at iserv dot net
Status: Bogus
Bug Type: Apache2 related
Operating System: Windows XP Professional SP2
PHP Version: 5.2.0
New Comment:
Alright then, I'll just have to make a note of this for next time.
Thanks :)
Previous Comments:
------------------------------------------------------------------------
[2006-12-23 16:04:15] tony2001@php.net
I don't think it's possible. AFAIK Windows does not provide any
information on this, so we got only the error message you see.
------------------------------------------------------------------------
[2006-12-23 15:54:04] asbo at iserv dot net
Thanks for the timely and polite reply; following the instructions
found in the manual worked -- my bad!
However, is there a way that the errors I experienced could be made to
be less vague -- not that it's not finding php_*.dll, but more
specifically a dependency of it?
------------------------------------------------------------------------
[2006-12-23 12:40:49] tony2001@php.net
http://php.net/curl - Note to Win32 Users: In order to enable this
module on a Windows environment, libeay32.dll and ssleay32.dll must be
present in your PATH.
http://php.net/mysql - MySQL is no longer enabled by default, so
the
php_mysql.dll DLL must be enabled inside of php.ini. Also, PHP needs
access to the MySQL client library. A file named libmysql.dll is
included in the Windows PHP distribution and in order for PHP to talk
to MySQL this file needs to be available to the Windows systems PATH.
------------------------------------------------------------------------
[2006-12-23 09:22:22] asbo at iserv dot net
Description:
------------
Note: The
Apache2 related may or not may be entirely accurate; I
don't know the scope of the issue.
After a recent re-install, I went to re-setup my Apache/PHP development
server, and ran into problems with getting extensions to load properly.
The following is set in my php.ini:
display_startup_errors = On
extension_dir = "./"
extension=php_curl.dll
extension=php_mbstring.dll
extension=php_mysql.dll
My path to php is d:\program files\apache2\php5.
My PATH environment variable has d:\program files\apache2\php5 set in
it.
PHP is being run as a module of Apache2.
I've tried numerous variations of extension_dir:
.
"."
.\
".\"
.\\
".\\"
./
"./"
d:\program files\apache2\php5\ext
"d:\program files\apache2\php5\ext"
d:\program files\apache2\php5\ext\
"d:\program files\apache2\php5\ext\"
d:\\program files\\apache2\\php5\\ext
"d:\\program files\\apache2\\php5\\ext"
d:\\program files\\apache2\\php5\\ext\\
"d:\\program files\\apache2\\php5\\ext\\"
d:/program files/apache2/php5/ext
"d:/program files/apache2/php5/ext"
d:/program files/apache2/php5/ext/
"d:/program files/apache2/php5/ext/"
Expected result:
----------------
The three extensions -- MBString, cURL, and MySQL -- load properly.
Actual result:
--------------
When Apache2 starts, I receive the following messageboxes:
"Warning"
PHP Startup: Unable to load dynamic library '*php_curl.dll' - The
specified module could not be found.
"Warning"
PHP Startup: Unable to load dynamic library '*php_mysql.dll' - The
specified module could not be found.
"Warning"
PHP Startup: Unable to load dynamic library '*php_curl.dll' - The
specified module could not be found.
"Warning"
PHP Startup: Unable to load dynamic library '*php_mysql.dll' - The
specified module could not be found.
* Represents any of the previously mentioned path variations.
Yes, I get each messagebox twice. So, cURL and MySQL are failing to
load -- but MBString isn't?? I've verified there is only one copy of
php_mbstring.dll on my computer -- the one in the /ext directory, right
next to php_curl.dll and php_mysql.dll.
phpinfo() confirms that mbstring is loaded, but cURL/MySQL are not.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=39936&edit=1