#40106 [Opn->Bgs]: Runtime - Unable to load dynamic library
| From: | tony2001@php.net | Date: | Mon, 15 Jan 2007 09:42:56 +0000 |
| Subject: | #40106 [Opn->Bgs]: Runtime - Unable to load dynamic library | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-107604@lists.php.net to get a copy of this message | ||
ID: 40106
Updated by: tony2001@php.net
Reported By: delontan at yahoo dot com
-Status: Open
+Status: Bogus
Bug Type: Unknown/Other Function
Operating System: windows 2003
PHP Version: 5.2.0
New Comment:
>anyone have any explanation? thanks!
Sure. Your PATH is different when you connect through the remote
desktop and Windows cannot find the required libraries.
Not PHP problem.
Previous Comments:
------------------------------------------------------------------------
[2007-01-13 02:19:01] delontan at yahoo dot com
hi tony,
i don't have a problem with the extensions being loaded at startup or
anything.
after setting enabled_dl = Off, the dynamic loading pop up still show
up (not when i restarted apache).
i noticed that it happens once in a while only when i connect to the
server using remote desktop control. one time after i logged on, the
other times during login screen.
all the startup dynamic loading erorrs for all extensions i am using
such as oci8, mssql, odbtp show up. i just have to close them. no
errors reported in error log like how it usually will.
anyone have any explanation? thanks!
------------------------------------------------------------------------
[2007-01-12 08:30:48] tony2001@php.net
OCI8 extension requires Oracle client, other extensions might require
other third party .dll's, which is described in the docs.
------------------------------------------------------------------------
[2007-01-12 00:06:54] delontan at yahoo dot com
i am using the extension_dir directive but enable_dl was also set to on
in php.ini. I set it to off now. Everything seems working fine. That pop
up problem happens once in a while. so, hopefully i will no longer
getting the pop up.
thanks!
------------------------------------------------------------------------
[2007-01-11 23:38:03] fmk@php.net
Sounds like you are using the dl() function to load the extensions.
That will not work with multithreaded SAPI's. You can load the
extensions with the extension=... directive in your php.ini file.
------------------------------------------------------------------------
[2007-01-11 23:28:13] delontan at yahoo dot com
Description:
------------
I've installed php 5.2 and update all related modules for oci8, odbtp.
Everything is working.
I use remote desktop to access the machine where i installed php and
apach 2.0.59. i installed php as modules instead of cgi/fast cgi.
during my development of php pages, unable to load dynamic library for
oci8, odbtp all came up from nowhere. i didn't see anything in error
log.
i remembered when there was (using cgi/fast cgi as parser last time)
memory leak or ?? reason, there will be php-cgi.exe stayed in windows
Task Manager's process list forever. i had to kill it manually before
it crashed my system. so, is this the effect of using modules as parser
and when seomthing went wrong, the dynamic window pop/show up? i just
have to close the window, everything is still working and running
fine.
plz advise. I've read all the similar post but it's different.
thanks!
Lee
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40106&edit=1