#40446 [NEW]: php.exe fails to start
| From: | a at b dot c dot de | Date: | Mon, 12 Feb 2007 11:45:39 +0000 |
| Subject: | #40446 [NEW]: php.exe fails to start | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-108729@lists.php.net to get a copy of this message | ||
From: a at b dot c dot de
Operating system: Windows XP SP2
PHP version: 5.2.1
PHP Bug Type: Reproducible crash
Bug description: php.exe fails to start
Description:
------------
PHP 5.2.1 (manually downloaded, extracted and copied to working directory)
fails to start either as a CLI or as an Apache module; Apache fails to
start also (though this may be a side-effect of something else).
Installation was through exactly the same installation process as earlier
upgrades (e.g., 5.0.x => 5.1). php.ini is being parsed (one early attempt
at the below reminded me to turn off a third-party extension with its
"Failed Loading" message).
Downgrading to 5.2.0 (through the same installation process) works
successfully. Installing 5.2.1 side-by-side with 5.2.0 in another
directory has the same result as below.
Reproduce code:
---------------
From the command line:
c:\> php -v
Expected result:
----------------
PHP 5.2.1 (cli) (built: Feb 7 2007 23:19:16)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
Actual result:
--------------
Fatal error: Allowed memory size of 128 bytes exhausted (tried to allocate
8192 bytes) in Unknown on line 0
--
Edit bug report at http://bugs.php.net/?id=40446&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=40446&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=40446&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=40446&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=40446&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=40446&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=40446&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=40446&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=40446&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=40446&r=support
Expected behavior: http://bugs.php.net/fix.php?id=40446&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=40446&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=40446&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=40446&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=40446&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=40446&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=40446&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=40446&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=40446&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=40446&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=40446&r=mysqlcfg