#40446 [Opn]: php.exe fails to start
| From: | a at b dot c dot de | Date: | Mon, 12 Feb 2007 11:46:41 +0000 |
| Subject: | #40446 [Opn]: php.exe fails to start | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-108730@lists.php.net to get a copy of this message | ||
ID: 40446
User updated by: a at b dot c dot de
Reported By: a at b dot c dot de
Status: Open
Bug Type: Reproducible crash
Operating System: Windows XP SP2
PHP Version: 5.2.1
New Comment:
(I said "edit"). Earlier upgrades included 5.1.6->5.2.0.
Previous Comments:
------------------------------------------------------------------------
[2007-02-12 11:45:39] a at b dot c dot de
Description:
------------
PHP 5.2.1 (manually downloaded, extracted and copied to working
directory) fails to start either as a CLI or as an Apache module;
Apache fails to start also (though this may be a side-effect of
something else).
Installation was through exactly the same installation process as
earlier upgrades (e.g., 5.0.x => 5.1). php.ini is being parsed (one
early attempt at the below reminded me to turn off a third-party
extension with its "Failed Loading" message).
Downgrading to 5.2.0 (through the same installation process) works
successfully. Installing 5.2.1 side-by-side with 5.2.0 in another
directory has the same result as below.
Reproduce code:
---------------
From the command line:
c:\> php -v
Expected result:
----------------
PHP 5.2.1 (cli) (built: Feb 7 2007 23:19:16)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
Actual result:
--------------
Fatal error: Allowed memory size of 128 bytes exhausted (tried to
allocate 8192 bytes) in Unknown on line 0
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=40446&edit=1